Author Topic: NC File Extra cuts  (Read 153 times)

0 Members and 1 Guest are viewing this topic.

Offline ShawnBassplayerTopic starter

  • Active Member
  • **
  • Posts: 28
  • Country: us
  • Gender: Male
NC File Extra cuts
« on: Jun 21, 2018, 03:25:10 PM »
Anyone ever find that CAMduct will add extra crap when it writes an NC file from something you've imported from DXF?  My boss likes me to cut art stuff now and then on our table.  I'll draw it in Autocad and import the DXF file into CAMDuct.  Everything looks good till I write the NC file.  If I then view the NC file to check (which I have to after I found extra cuts when I'm actually cutting the metal)... I see when it jags out and adds extra loops and such. 

Offline jimbon

  • Full Member
  • ***
  • Posts: 134
  • Country: us
  • Gender: Male
Re: NC File Extra cuts
« Reply #1 on: Jun 21, 2018, 04:58:20 PM »
That's happened once or twice to me.  I found zooming in on the .DXF in AutoCAD and getting rid of very small lines and arcs, and just extending the connecting line on either side did the trick.  Run a purge, audit, and overkill just to make sure your .DXF is nice and clean.

Also, when you bring it in to CAMduct, make sure you click down to your profiler and make sure your islands are coming out okay.

Hope that helps!
Ver. 2017.0.0.F (26)  -  Building Design Suite 2017  -  CADmep, CAMduct, and ESTmep 2017  -  Building Data and SysQue 2017
Windows 7 Professional x64  -  Intel Core i7-3630QM @ 2.40 GHz  -  8 GB RAM  -  AMD FirePro M4000

Offline Cameron

  • Active Member
  • **
  • Posts: 12
  • Country: us
  • Gender: Male
Re: NC File Extra cuts
« Reply #2 on: Aug 06, 2018, 05:01:27 PM »
We get stuff like this happening randomly after modifying parts in CAMduct. Typically using the repair tool fixes this but not always.

Offline Darren Young

  • Premier Member
  • *****
  • Posts: 1358
  • Country: us
  • Gender: Male
    • Hermancon Company LLP
Re: NC File Extra cuts
« Reply #3 on: Aug 06, 2018, 05:07:14 PM »
You can play with the Manufacturing -> Tool Defaults -> Options to vary the results.

Also recommend making sure your geometry in CAD can be joined into a single PLINE to verify that there are no gaps/overlaps prior to importing.

Offline lsm_drafter

  • Senior Member
  • ****
  • Posts: 410
  • Country: us
Re: NC File Extra cuts
« Reply #4 on: Aug 10, 2018, 06:20:47 PM »
You can play with the Manufacturing -> Tool Defaults -> Options to vary the results.

Also recommend making sure your geometry in CAD can be joined into a single PLINE to verify that there are no gaps/overlaps prior to importing.

+1

I found that converting all the lines and arcs in AutoCAD to a single, joined, polyline and then purging the dwg file before saving as a dxf helped keep Camduct happy. Text and dimension objects really give CAMduct fits. Even if you generate dimensions in the dwg and then delete them before creating the dxf can cause issues.
You've got to eat them before they eat you!
CADmep 2015, SP1, AutoCAD 2015 x64
Windows 10 x64 on Samsung 840 120gb SSD, Core2Duo 3.33ghz 8gb RAM
2GB NVidia GeForce GTX660, Dual 22" Monitors