Author Topic: C# .NET Addin not able to sign because Fabrication API.dll is not strongly named  (Read 203 times)

0 Members and 1 Guest are viewing this topic.

Offline srivesTopic starter

  • Active Member
  • **
  • Posts: 3
  • Country: us
  • Gender: Male
In Visual Studio 2019, I have created a C# .DLL (.NET Framework 4.7) addin for CAMduct 2020. The DLL/Addin functions as expected, as long as it is not signed.

When I sign it in Visual Studio, Visual studio warns me that Fabrication API.dll is not strongly named. It is just a warning, so I keep going. But when I try to use this signed version of the addin inside CAMduct, it won't load because even though it is signed, one of its components is not.

I have tried to decompile Fabrication API.dll and rebuild it so that it is strongly named (but this isn't possible because it is built in such a way that decompile is possible, but not recompile -- I assume because it marshals out to C++).

How have people gotten around this problem? Is it a problem others have experience, or maybe it is peculiar to my install of CAMduct (which is still evaluation -- as I am building this addin for a mechanical contractor shop).


Offline mix_forever

  • Active Member
  • **
  • Posts: 4
  • Country: pl
  • Gender: Male
Same problem... :'( :'( :'(
Is there any way to resolve this?

Offline effimero89

  • Full Member
  • ***
  • Posts: 193
  • Country: us
  • Gender: Male
See I thought signing was suppose to fix that error.

I guess the first question is do the out of the box addin's work? like the ones from autodesk?
CAMduct 2018/2019
Fabrication API
Revit 2017/2018/2019

Offline cadbob

  • Premier Member
  • *****
  • Posts: 2715
  • Country: us
  • Gender: Male
just throwing a dart here, but have you tried re-booting with driver signing disabled?
When someone asks where you see yourself in 5 years... Buddy, I'm just trying to make it to Friday. :)