XtraCAD.com

Fabrication in Revit® => Fabrication Parts in Revit® => Topic started by: BradleyFletcher on Oct 14, 2021, 16:55:41 PM

Title: CADmep to Revit Issues
Post by: BradleyFletcher on Oct 14, 2021, 16:55:41 PM
I am trying import Fabrication CADmep content into Revit but I am having some difficulties, I have a Ductwork CADmep Model and a separate Electrical Containment and Piping Model that both use different databases. I have the DWG’s and both separate databases.

A supplier/subcontractor has produced these drawings for us and has issued us the databases so we can perform an MAJ Import into Revit, one company has produced the Ductwork Model and the other Company the Mechanical and Piping Model.

My first issue is when I am opening the DWG’s on my end in Fabrication CADmep, I am getting the ‘This Drawing contains a Database that is different from the Working Disk Database’ error yet I can’t find any difference in the copy of the database I have to the suppliers/subcontractors copies, GUID is the same.

And when I Import the MAJ into Revit that I have generated from the DWG, I am greeted with the ‘This Job Contains No Fabrication Parts error, I have tried opening MAJ through Openjob and overwriting the GUID and doing SaveDatabaseToDisk, that lets me import the MAJ but within Revit the Fab parts are missing fittings and are not connected properly and some lengths of straight runs are different, it doesn’t reflect the CADmep Model.

The two companies I am working with both have Revit they have tried exporting an MAJ but when this in imported into Revit on their end they are greeted with the ‘This Job Contains No Fabrication Parts’
How can I get around this? I need to get the CADmep content into Revit.

Thanks

Title: Re: CADmep to Revit Issues
Post by: eknight on Oct 14, 2021, 17:59:58 PM
Just a thought but are you able to get into the Manage Database section and find any temporary database connectors, materials, seams or etc. and make them permanent, then try importing the maj into a blank Revit file? 

In the past if there was a temporary connector, material or seam definition on one of the parts in the file Revit would reject the entire import with the error you gave.
Title: Re: CADmep to Revit Issues
Post by: Axl on Oct 14, 2021, 18:24:21 PM
We recently got an issue like that, check this article,
https://knowledge.autodesk.com/support/revit/troubleshooting/caas/sfdcarticles/sfdcarticles/Revit-Error-Fabrication-job-contains-no-parts-when-importing-Maj-files.html
Title: Re: CADmep to Revit Issues
Post by: BradleyFletcher on Oct 16, 2021, 16:30:31 PM
I have now got the Ductwork Model to import, using the method suggested by eknight, but when the model is imported into Revit as an MAJ and converted to FAB Parts, I am having an issue where the Ductwork appears to move when orbitting, has anyone had this before?

It also sometimes appears as though it is disconnected even though it is connected?

I have attached Image of this.

I am using CADmep 2021 and Revit 2021 with latest updates, I have tried this process on 3 different PC's and am getting  the same issue, they are different spes two have Quadro GPU's and other one Intel HD Graphics, so I dont belive it is a hardware or driver issue.

When the model is linked into another model the same behaviour also occurs.

Has anyone got any solutions on to resolve this?